Cali EV fuel injection

Post Reply
iant-s
Posts: 18
Joined: Sun Nov 29, 2020 8:31 am
Location: Staffordshire

Cali EV fuel injection

Post by iant-s » Sat Jan 02, 2021 5:30 pm

I cannot get my 1998 EV Guzzi California based car to start. It last ran perfectly 2 years ago and has been stripped and rebuilt over that time. I have tried everything I know but have run out of ideas so am looking for advice and any ideas. I have all the documents and wiring diagrams printed off and available.
From my diagnosis, the problem is that there is no negative switched signal to the injectors. I have pressurised petrol at the injectors. I have constant 12 volts at each injector fed from the CPU relay. If I apply 12 volts + and - to an injector it squirts petrol into the inlet. Whilst I have tested each sensor as much as possible with a multimeter, one or more might be failed, but they all appear to be doing the correct things as described in the books.
The manuals tell me the injectors have a constant 12 volt supply to them and are operated by the CPU providing the negative and so opening the injector at the exact time and duration of squirt. It is not doing this and I am stumped.
I have compression and the exhaust and intakes are all clear. I have good sparks which appear in time to the cylinders.
Has anyone seen such a situation before? I have spent 3 days on it now!!! Can anyone help please.

Doverhay
Posts: 217
Joined: Thu Sep 27, 2018 6:43 pm
Location: TA66NN

Re: Cali EV fuel injection

Post by Doverhay » Sat Jan 02, 2021 6:42 pm

Have you drained the old fuel and refreshed with new? Modern fuel just doesn’t age very well. Just a thought 🤔

peakrock
Posts: 114
Joined: Thu Sep 27, 2018 4:52 pm
Location: Wreningham

Re: Cali EV fuel injection

Post by peakrock » Sun Jan 03, 2021 12:11 pm

When I built my EFI engined Triking last year I couldn't get it to run initially either. So after all the obvious things to check I did other things like;
Swap the injector plugs over and trying it
Swap the plug leads over and trying it
Put the injector plugs back where they were and trying it
Finally put the plug leads back where they were.
Double check the sensor plugs are on the right sensors
Soaked a couple of small pieces of rag in petrol and placed in the injector opening and tried it - I've done it several times over the years with engines that wouldn't start and it's been useful.

None of the above got the engine running and I'd checked for a spark at the plugs but - when I spray painted the engine I'd got silver paint over the plug insulators and after I cleaned it off the engine ran ok - apart from needing the injectors serviced as one was sticky..

You may have done most or all of the above but I've always found it helpful to be able to definitely rule things out like crossed leads etc. Is it Sherlock Holmes who said "Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth"

Good luck
Dave

iant-s
Posts: 18
Joined: Sun Nov 29, 2020 8:31 am
Location: Staffordshire

Re: Cali EV fuel injection

Post by iant-s » Sun Jan 03, 2021 12:38 pm

I have had a good suggestion from a Guzzi club member who has pointed out that the ground connection which is provided by the CPU to open the injector is of such a short duration that a multimeter cannot respond to it fast enough. He suggests an oscilloscope - which I can get hold of. Getting deep now Chaps!

Another has told me of an injected Triumph where he found the injectors would work when a battery was connected to them, but not from the CPU. No we this sounds familiar. He said it had stood for 3 years and the old petrol had gummed the injectors up so they WOULD open but slowly. Also the CPU only provides an electronic ground via a transistor. It's not a "solid" connection to earth such as a relay would provide. His solution was simply to get the injectors properly cleaned.

peakrock
Posts: 114
Joined: Thu Sep 27, 2018 4:52 pm
Location: Wreningham

Re: Cali EV fuel injection

Post by peakrock » Sun Jan 03, 2021 5:04 pm

I had my injectors cleaned and serviced by this company and was pleased with the result, they know about the injector type and have the necessary parts to service it in stock..

https://injectortune.co.uk/index.html

iant-s
Posts: 18
Joined: Sun Nov 29, 2020 8:31 am
Location: Staffordshire

Re: Cali EV fuel injection

Post by iant-s » Thu Feb 18, 2021 10:18 pm

It gives me great pleasure to announce I have my engine running. As said in original post I had all the books and manuals downloaded and a suit of test equipment available. I tested everything, every wire, every connection was cleaned and re-tested. I rpelaced the crankshaft and camshaft sensors even though the originals gave correct test readings (plus I found generic replacements from Lucas for £17 each instead of Marrelli for £70 each).
Several websites had said the ECU was of a well proven type and they are indeed used on Fiats, Lancias, Ferraris, Ducatis. They all had a consensus that the very last thing that would be wrong was the ECU having failed. Well after 4 weeks of trying I decided it HAD to be my ECU - there was nothing left. Was it not Sherlock Holmes who said something along the lines of "When you have eliminated every other option, the remaining option, no matter how impossible.......My ECU still had the factory seals intact and the bike was running perfectly originally. With some trepidation I broke these seals and remoeved the upper and lower lids. The PCB was covered in aluminium oxide and I saw one corroded track straight away.
Anyway a replacement was £200 for one that was even older than the one I had (1998 is a long time ago), so I took mine to Industrial Electronics of Fenton, Stoke-on-Trent. This is an electronics and test meter repair specialist I have used several times since 1982 was the first time (flipping eck!) This excellent establishment returned it 6 days later. Plugged it in and the engine burst into life at the first touch of the starter button. The Tech at Ind. Elect said I should try it and once happy with it seal it up with bathroom sealant. They had found and repaired 3 PCB tracks and 2 dry joints, but these were all underneath a large I.C. chip which they had to unsolder and remove to make the repairs. There was no way I could have identified these issues so I was very happy to give them the £120 repair fee.
Below is the oscilloscope screen when I was testing the crank and cam sensors.
scope screen.jpg
Yellow trace crankshaft. Blue trace camshaft.
Flywheel has 4 lugs and the cam has one. The cam goes round at half engine speed. The cam one only generates 100mV - not much at all. The sensors are the same but it makes less signal because of the lower speed of the lug passing the sensor.

iant-s
Posts: 18
Joined: Sun Nov 29, 2020 8:31 am
Location: Staffordshire

Re: Cali EV fuel injection

Post by iant-s » Fri Feb 19, 2021 9:14 am

Further to the above I guess I should say that after breaking the factory seals and removing the 8 small screws I noted that the lids were not actually sealed down. The white oxide powder was from surface corrosion on the insides of the lids. Now the Weber Marelli P8 ECU is primarily a car unit so should live under a car bonnet or inside a dashboard. My EV Cali had had a hard life permanently outside on the street. That's why it looked so rough. So 23 years of exposure to moist air had allowed some corrosion - primarily in the one place under a chip.
Now the pcb has had a fresh coat of insulating varnish, there is a square of corrosion inhibiting paper inside and the lids have been mirror poished inside and are silicone sealed down. Good for another 30 years I would say.

peakrock
Posts: 114
Joined: Thu Sep 27, 2018 4:52 pm
Location: Wreningham

Re: Cali EV fuel injection

Post by peakrock » Fri Feb 19, 2021 11:50 am

Glad to hear you've sorted it out and that the ECU has been repaired. I do wonder how long some electronic devices will last - I have touch sensitive light switches in a couple of rooms which can also fade up and down - they must be 40 years old now and are used every day and work fine.

Let's hope the ECU's last longer still !

jtdesign
Posts: 23
Joined: Sun Sep 30, 2018 8:47 am
Location: Peak District

Re: Cali EV fuel injection

Post by jtdesign » Mon Feb 22, 2021 9:33 am

Just a word of caution on using silicone sealants for electrical / electronic work. There are two flavours of RTV silicone which have different inhibitors - either acetic acid or alcohol. The acid one (smells of vinegar) releases fumes during curing that react with copper wiring and circuit boards to form a green corrosion that is conductive and not good. The alcohol one is OK for use on electronics. In the ranges of building sealants the Soudal silirub2 is an alcohol based RTV but there are plenty of others as well. The cheap bathtub sealants seem to be mostly acid based.

John

iant-s
Posts: 18
Joined: Sun Nov 29, 2020 8:31 am
Location: Staffordshire

Re: Cali EV fuel injection

Post by iant-s » Thu Mar 04, 2021 4:12 pm

I checked this out and you are correct. Particularly where people have been encapsulating components. I sealed my ECU lids down with minimal bead of silicon so I really hope it's cured and the contained gas will disperse or go inert over time. Wish I had known this earlier.🙁

Post Reply